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introduction

DECgis, formerly known as MapWindow, is a compact freeware GIS software
package that makes viewing and using GIS data easy, specifically designed for
DEC employees. DECgis provides core DEC GIS functionality in a simple, easy
o use environment.

Starting DECgis

The DECgis program is located on your start menu — Start / Programs / DEC /
GIS / DECgis 2006, and also as a shortcut on your desktop.

When starting DECgis you may be presented with a window that allows you to
perform particular shortcuts when starting a new DECgis session, seen below:

b Add data to this project

3% Qpen aproject

6 Getting started with MapWindow

‘f,) View MapWindow help file

* Department of
: TRy s et iam .. .
* Environment and Conservationgld viit www Mapwindow.com

B Show this dialog at startup

Close }

ROV |

You can uncheck the “Show this dialog at startup” to stop the window from
appearing every time you start DECgis, but there is no need to do so for this
fraining course.



The DECagis Environment

Below is a picture depicting the DECgis Interface, and the components that
comprise it.
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The main component of the DECgis interface is the View, where data is
displayed. The legend presents all of the map layers that are being displayed on
the view. Layers are respective datasets, which with DECgis are usually
shapefiles. The legend also provides access to layer properties and other layer
related functionality. The Preview Map provides an overview of where the extents
of your view are in relation to the complete extent of all your map layers, ie if you
are zoomed in on the Bunbury Area, the Preview Map will show a red box over
the South West of Western Australia to show where you are looking in the total
scheme of things.

You will get to have a play with all of these different components in the coming
exercises.



Plugins

If you are familiar with ArcView GIS software, then Plugins are exactly the same
as Extensions. DECgis Plugins provide functionality that extend the default
DECgis functionality. There are a number of DECgis Plugins that provide useful
functionality that many GIS users will utilise. These Plugins are:

* Shapefile Editor
° GIS Tools

These Plugins will be examined in further detail shortly.



Working with Data

Adding Data

To be able to view and query data in DECgis, you must first add the data into
your DECgis project. A DECgis project is basically a blank template which you
populate with datasets. When you add a dataset into DECgis, you are adding a
reference to the dataset, not the actual dataset itself. So when you remove a
layer from a DECgis project, you are not deleting the dataset from your computer,
you are just removing from use with the particular DECgis project. One dataset
can be loaded into any number of DECgis projects. Adding a dataset is achieved
by pressing the “Add Data” Button from the DECgis Button Bar:

aver
Clear Lavers

Press the “Add Data” Bution

After pressing the Add Data Button, you will be asked to select the data you wish
to add.

Navigate to the
“C:\GIS1-Corporate\data\Administration_Boundaries\State” folder, select
the “dec_regions_2006_mga50.shp” shapefile, then press OPEN.

NB: For the purposes of this training course, it is assumed that you are
connected to a V: drive (GIS server or external hard drive). If you are on a laptop
supplied as part of an organized training course then the data is probably stored
locally on the laptop, so you will need to substitute C: for V: every time you load
datasets throughout these notes.

Have a play with the Zoom and Pan functions to navigate your way around the
DEC Regions:
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The Preview Map

The Preview Map is not only a way to show where it is you are looking on your
view, but also a way to pan your view.

Click the “Edit -> Preview Map -> Update” Menu ltem

This should display your entire DEC Regions layer in your Preview Map window.
You should notice a hollow red box depicting where you are looking on your view.
When you update a preview, the Preview Map will display the maximum extents
of all of the layers you have loaded in your view, as well as displaying those
layers which you have tumed on. You can turn the display of a layer on and off
by simply checking or unchecking the checkbox direcily to the left of the
respective layer name in the legend. Turn the DEC Regions layer off and then
update the preview again. You will notice that the preview is now blank, because
no layer was turned on at the time of the update. If you turn your DEC Regions
layer back on and then update the Preview Map again the DEC regions should
reappear.

If you move your mouse cursor over the hollow red box on your Preview Map you
will notice that the cursor changes, indicating you can move the red box, and
hence move your view extents, providing you large scale panning functionality.
You can pan by clicking on the red box, holding the mouse button down,
repositioning the box, and then release the box when you are happy with your
new extents. You should notice that your view has changed accordingly.



Identifying a Feature

Your view shows the spatial representation of your layers, which in this case is
the DEC Regions across WA. The datasets you add to DECgis not only have a
spatial representation, but for each shape in the dataset there is information
attached. This is the fundamental basis of GIS software, linking the “Where is”
component with the "What is” component.

Click the Feature Identifier Tool on your main toolbar L]

You will notice that a Feature Identifier Results box has been displayed, and tpat
when you move your cursor over your view, that the cursor has changed to a 1

Click on the different DEC Regions in the view to see the respective Region
names.

Note that you can drag a box over a number of shapes in the view to identify the
information of all the features contained in the box you have selected. You can
use the drop down list at the top right of the Feature Identifier Results box to filter
through all of the shapes that intersect the box you have dragged out on your
view. Note that the shapes are sorted by default by the Shape Index field, but
you can change this in the top left drop down box.

Changing the Order of Data

So far we have only added one layer to our view, but we can add many more.

Add the “V:\GIS1-Corporate\Data\Man_Made_Structures\State\
townsite_points_mga50.shp” dataset to your DECgis project.

You will notice your legend now has two layers. The town sites dataset which you
have just added is a point dataset, whereas the DEC Regions dataset is a
polygon shapefile. If you place a point shapefile behind a polygon shapefile then
the polygons will cover the poinis so you wont be able to see them, hence the
points need to be on top of the polygons.

In DECgis the top layer in your legend will be displayed in front of all the other
layers, hence point layers should always be placed on top of polygon layers in
the legend. You can change the order of layers in the legend by simply clicking,
and holding down the click on a layer, and then drag the layer up or down.

Drag the “t@wnsite_;poinisﬁmgaSO” layer below the
“dec_regions_2006_mgas0” layer to see what happens, then drag the
“townsite_points_mga50” layer back to the top.
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Crealing Shapefiles

You can create and edit shapefiles in DECgis. Shapefiles are the native vector
file format for DECgis, just the same as ArcView. Shapefiles contain points, lines
or polygons. These points, lines and polygons can be used to represent any
number of things. For example townsites would be represented by a point
shapefile, roads would be represented by a line shapefile, and remnant
vegetation would be represented by a polygon shapefile.

Creating shapefiles and populating them with shapes is a way of storing
information and data that you will need to use in the future, or need to distribute.
For example if you are keeping a log of areas which you have surveyed for flora,
then you can store these areas in a shapefile, and use this shapefile as a
reference for the future. Shapefiles allow you to permanently store spatial
information.

To be able to create and edit shapefiles you will need to turn on the “Shapefile
Editor” Plugin:

Turn on the “Shapefile Editor” plugin (Plugins -> Shapefile Editor)

You will notice some more buitons and a “Shapefile Editor” menu have been
added to your DECgis project.

Press the “Create new Shapefile” Button: <!

You can now specify the type of shapefile you wish to create and where you want
o save it.

Set the “Shapefile Type” to “Polygon”, then use the “...” button to the right
of the “Filename” textbox to navigate your way to “C:\GIS1-
Corporate\data\training” and call your shapefile “my_tester”. Press “Save”,
and then “OK”.

Note that shapefile names (and the paths they are located in) should not
contain any spaces. This is why we are using an underscore in “my_tester”,
instead of having “my tester”.

You will then get a message box pop up on the screen. This message is letting
you know that to create shapes you will need to have a layer loaded to provide a
reference to create shapes from. If you try to create shapes on a blank view, then
your new shapes wont align correctly with other datasets. Have a read of the
message then dismiss it by clicking OK. You will then notice that “my_tester’ has
been added to your legend and is now selected. .
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Adding Shapes

You will now create a new polygon in your “my_tester” layer.

L3
Click the “Add new shape to current shapefile” button: 3"

Note: This function will add a new shape to whatever layer you have selected in
your legend, so _make sure that you are not adqu any new_shapes to a
* Corporate Dataset such as CALM Estate.

Trace out a polygon shape by single clicking consecutive points, and then
right click to close the polygon

Have a bit of a play and create a few polygons. You can also click your last point
on top of your first point to close a polygon, but the right click is easier.

Deleting Shapes

To delete a shape you will need 1o select it ﬁrst,'using the “Select Shapes”
button: &

Select one of the shapes you have created in your “my_tester” layer. The
shape should turn yellow. Then press the “Remove Selected Shape(s) from

shapefile” Button: ¥
Say Yes when you are asked if you are sure you want to delete the shape.

DECqis doesn’t have an undo feature, so it is serious when it asks vou if you are
sure.

If you want to select more than one shape to delete, select the first shape, then
hold down the CTRL key whilst you select all the other shapes you would like to
delete. You can then press the “Remove Selected Shape(s) from Shapefile”
button to remove the shapes you have selected. Note that the select button will
select shapes from whichever layer is active in your legend. If a layer is active it
will have a grey box around it, which all of the other layers will not have. To select
a layer to make it the active layer, simply left click the middle of the layer in the
legend.
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Editing Shapes

DECgis gives you the ability to edit shapes you want to change. You can edit,
add and delete vertexes of shapes. Vertexes are just the corners or points that
comprise a shape. For polygons, the vertexes will be all of the corners, whilst for
a line the vertexes are every point or junction along the line. For a point shapefile,
a vertex is actually the point, hence when you move the vertex of a point you are
actually just moving the point.

Click the “Move an Existing Vertex in a shape” button: &

Move your mouse cursor over your polygons in your “my_tester” layer, and
when the vertexes turn blue, click and hold down on them, and move them.

Remember that a vertex must exist before it can be moved.

You can use the “Add Vertex” # and “Delete Vertex” ® buttons to add and
delete vertexes from your shapes as well. Have a play with moving, adding and
deleting vertexes from your polygon shapes in your “my_tester” layer.

Shapefiles can be used in multiple DECgis projects, and can also be viewed and
edited in other GIS software such as ArcGIS and ArcView.

Group Lavers

DECgis allows you to group layers, so that you can turn multiple layers on and off
easily (jump to page 14 if you are not interested in this topic). You will add some
tenure layers to your project under a tenure group.

You will notice that the three layers you have added to your project have all been
grouped under a “Data Layers” heading. This “Data Layers” is actually a group. If
you check and uncheck the “Data Layers” group you will see that all of your
layers get turned on and off respectively.

Right Click anywhere in the legend, and then select “Add Group” from the
Context Menu that pops up.

You will notice that a new group aptly called “New Group” has been added to
your legend.

Right click on the “New Group”, then select the “Properties” option from
the Context Menu that pops up.
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Change the name of the group to “Tenure Group”, by typing over the
previous name of “New Group” in the properties window. -

Close the properties window by clicking the close button at the very top
right of the properties window.

The new group you have added to your legend should now be called “Tenure
Group”. We will now add some tenure layers under the “Tenure Group”.

Right click on the “Tenure Group”, then select “Add Layer” from the
Context Menu that pops up.

Navigate to the “V:\GIS1-Corporate\Data\Tenure\scdb\state” directory, then
select the following files, by holding down the Cirl button and clicking on
them:

> other_crown_reserves_mga50.shp

° unallocated_crown_land_mga50.shp

° unmanaged_reserves_mga50.shp

Press Open

You should now see three tenure layers added under “Tenure Group”. If you
have a large number of layers added to your project, your view may get cluttered,
which will make it hard to understand. By grouping your layers you can
systematically turn a group of layers on and off, so that you don’'t have to have all
of your layers visible at the same time. When you want to show and query tenure
layers you can turn the tenure group on, but it may not be necessary or desirable
to have these layers tured on at all times.

Right click on the “Tenure Group”, then select “Remove Group” from the
Context Menu, to remove the group from your project.
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Laver Properties

Changing Symbology

In DECgis you have the ability to change the symbology of a layer. The
symbology of a layer depicts how the layer will be displayed in your project. You
can change a number of layer symbology properties, such as outline colour,
whether or not to show the fill of a polygon, and to display dlﬁeren‘r features of
your layer in a different colour. .

Right click on your “dec_regions_2006_mga50” layer in your legend

A popup menu will appear with a number of options. The one we are interested in
is “Properties”.

Click the properties item of the popup Context Menu

You will now be presented with the “Legend Editor” dialog for your
“dec_regions_2006_mga50” layer which will allow you to change it's symbology.

False
gend Picture [::] [none]
EE! witioloas | i
.. Coloring Scheme ,[Nnne]
i D|sp!ay Name - calm_regions_mga50
* Dynamic Visibility Disabled

< Fill Color 1 197,194, 182
- Fill Style [T tsMone
- Lahel Setup Edit...
Line Style 1 lsMone
Line Width E‘E 1
Dutline Color B 2353, 207
- Show Fill True
Display Name

The name shown in the legend.
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Have a play with the different “Display Properties” to change the
appearance of the “dec_regions_2006_mga50” layer, such as line style and
width, fill style and colour, outline colour and the show fill property.

Color Schemes

You have just had a play with the simple display properties of your layer. DECgis
also allows you to set more complex symbology for your layers through the
“Coloring Scheme”. You can use a Unique Values, Equal Breaks or Continuous
Ramp Coloring Scheme, which will all base symbology on an attribute from your
layer. By setting a coloring scheme you are choosing to colour up shapes within
the shapefile differently, depending on what information is attached to the
respective shape.

¢ Unique Values

Click on the “Coloring Scheme” property. A small button to the right will
now appear .=, Click this button.

You will now be presented with the “Coloring Scheme Editor” dialog:

B+—-7-

Field to color by: j
Number Format; éﬁlutomatic [Shortest Text] :j
[Color[valuels) i flTem ]

......

H
Cancel % 7 Preview
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The button at the top right of the Coloring Scheme Editor dialog, the one that
looks like lightning, allows you to specify what type of colour scheme you would
like to apply.

Click the dropdown arrow attached to the “Predefined Coloring Scheme”

button é’f{’? , and select “Unique Values” from the menu.

You will notice that your Coloring Scheme Editor dialog is now filled with all of the
DEC Region names. This is because every unique value from the “Regions” field
has been assigned a different colour. So basically unique values assigns every
respective value for a selected field of your layer a different colour.

Press OK, then close the window to get out of the Legend Editor.

You will notice the colour of your layer has now changed. You will also notice that

there is an expand " button = “1Ef directly to the left of vyour
“dec_regions_2006_mga50” layer. Press this button to expand the legend
information for the layer.

Add the fuel age layer from your DEC Corporate Data
(V:\GIs1-Corporate\datal\fire\state\fuel_age mga50.shp).

* Equal Interval (Breaks) and Continuous Ramps

These colouring schemes are a bit more advanced, so jump to page 19 if you are
not interested in these topics.

The Equal Interval classification is most useful for numeric fields of layers, but
can also be used for text fields. This classification will divide the range of values
of a specific field into groupings of equal interval, e.g. 0 - 5, 510, 10 — 15 etc.

Zoom to the fuel age layer by right clicking on “fuel_age_mga50” in the
table of contents and selecting “Zoom to Layer”.

Open the Legend Editor for your fuel age layer (Right Click on the layer and
select “Properties™).

Open the Coloring Scheme Editor (Press the button directly to the right of
the “Coloring Scheme” option text box).

At the top of the Coloring Scheme Editor dialog, select “YSLB” as the
“Field to Color By”.
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YSLB stands for Year Since Last Burnt. In relation to the fuel age layer, the YSLB
field is a numeric field, so we will use the Equal Interval Coloring Scheme to color
the polygons respective of how long since they have been burnt.

Press the “Predefined Coloring Scheme” Button (Lightning bolt), and select
Equal Breaks as the scheme. You will then be prompted to select how
many breaks (groupings) you would like to use, enter 5 and press OK.

You will notice that 5 equal intervals have been created to distribute all of the
values in the “YSLB” field into equal groupings.

Press “APPLY” and. notice the change.

You can also manually adjust the respective colours and intervals, along with the
text for each interval, which is what will appear in the legend.

Manually change the interval “Values” so that the intervals round to whole
numbers, ie 1 -6, 6 — 12 etc. Press Apply.

The Continuous Ramp Coloring Scheme is a really good way of representing
magnitude, by using lighter shades of a colour to show low values, and darker
shades to signify higher values.

Press the “Predefined Coloring Scheme” Button (Lightning bolt), and select
Continuous Ramp as the scheme.

You will now be able to specify the number of ramp categories, along with the
start and end colours. The end colour will be the colour of the highest value for
your field, whilst the start colour will correspond to the lowest value in your field.
Click on the Start Colour and select a light blue

Click on the End Colour and Select a dark Blue.

Change the number of breaks to 10 (the shapes will be divided up into ten
equal categories for colouring).

Press OK, then Apply. Do not close the Colouring Scheme window just yet.
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Saving and Loading Colour Schemes

In DECgis you can save and load colour schemes, to reuse symbology in
different projects.

in the Color Scheme Editor for DECgis, press the “Export Coloring
g
Scheme” button

Save the coloring scheme in the “C:\GIS1-Corporate\data\training\” folder -
and call it “myleg”, press SAVE.

Now select the “Unique Values” Coloring Scheme.

Press the Import Coloring Scheme button ¥ to reload your saved legend.

Choose your “myleg” file, press OPEN, then press APPLY .

Press OK to exit the Colouring Scheme window, then close the Layer
Properties window.
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Labeling

Be aware that unlike other packages such as ArcView, the labeling functions are
very basic. When you have created the labels and they are on the screen, that’s
it. You cannot edit individual labels. Also DECgis cannot label shapefiles that are
stored in read-only folders, as it needs write access. Unfortunately this is the
~ case with the GIS servers (V:), in which case you would copy the data locally if
you needed to use labeling.

The labeling functionality automatically positions labels on your view, based on
an atiribute column of the respective shapefile.

Turn all of  your layers off (uncheck) apart from
“dec_regions_2006_mga50”.

Right click on your “dec_regions_2006_mga50” layer in your legend.
Click the properties item of the popup Context Menu.

Click on the “Label Setup” Option on the properties window, then press the
A%zi button to open up the Shapefile Labeler window.

You will now be presented with a dialog box that will allow you to place labels on
your view.

Label by Field: ~ {None vl

~Label Propetties ~Label zoom extents e

Font:  {Microsoft Sans Serif, 8.25

I Enable label extents

Color: §Color [Black]

Hign Temer

I Use Label Shadow
:{ Color fw/hite] g

{7 Scale Labsls

Reset Font Scale !

I Use Label Colision Avoidance

= 0K % Close %
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Select “REGION” as the “Label by Field”.
Select whatever font, alignment and shadow you like, then click Apply.

If a message comes up “An Error Has Occurred”, then click the “No, Don’t Send”
box (this is a known bug).

The regions should now have their region name in them.

There are a couple of more options on the labeler form. You can use the “Enable
Label Extents” option to make the labels not appear when you zoom out too
much. To use this you will need to check the “Enable label extents” checkbox on,
and then press the “Set Current Map Extents as Label Extents” button when you
are zoomed out to the maximum extents that you want the labels displayed for.
Once you have applied this whenever you are zoomed out to the set extent level
or more, the labels will not be displayed.

The “Scale Labels” option sets the labels to increase or decrease in size when
the user zooms in or out of the view. If you choose to use the “Scale Labels”
option then the labels size will stay relative to your shapes. If you do not check
this option then your labels will stay the same size relative to your screen, no
matter how far in or out you are zoomed.
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Making a Printable Map

Printing

To print out a map from DECgis, you simply press the “Print” item from the “File”
menu on the main menu bar.

Press the File -> Print item.

You will now be presented with the generic print dialog which allows you to
specify a map title and whether to include a legend, scale bar or north arrow.

Optionz
. " Properties g
i Legend {7 Scale Bar
. - . i
I Visible Layers Only 1 North Arrow  Preview !
7 Tite
i A g
. | i
Print ! Cancel |

Check on the Legend, Scale Bar, North Arrow and Title options, and enter
in a Title of DECgis Training Map.

The properties button will allow you to specify the printer to use, page size and
orientation, and any other printer specific setting.

Press Preview to view your map

The ability to check on or off the legend, Scale Bar, North Arrow and Title is the
only way you can change the appearance of your map. If you require a little more
flexibility in making your maps, there is another route you can take with DECgis;

Close the Preview window.

Cancel the Print window.
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Copyving a View or Legend

DECgis provides the functionality to be able to copy the Map, Legend, Scale Bar
and North Arrow to your computer clipboard, so that they can be directly pasted
into other software packages, just like the standard Copy and Paste functions in
Microsoft Office software.

For example, you can directly copy and paste all of your map elements into
Microsoft Word, then move them around, add in pictures and create your own
map template. You can even create a map template which you use as your
standard map template for creating all your maps with.

Copy your View (Edit -> Capy -> Map) and paste it into a Microsoft Word
document.

Now Copy your Legend (Edit -> Ccpy -> Legend) and paste that into you're
Microsoft Word Document.

Do the same for your Scale Bar and North Arrow, then design your own
map.

Note: Do not resize the Map or the Scale Bar elements as this will distort the
original scale values.
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Tables

So far we have been focusing on the graphic side of DECgis, but now we will
have a look at the information behind these graphics. All GIS software
incorporates the “where is” with the “what is”, in other words where is what and
what is where. Clear as mud? Well basically every shape we look at on our
DECqgis View will have some information behind it. For the DEC Regions, the
region name is the information behind it.

in DECgis the information attached to the shapefiles is accessed via tables, using
the “Table Editor”.

Select the “fuel_age_mga50” layer in your legend. Press the “Table Editor”
button to open the table for this layer.

You should now see all of the information for the fuel age layer. The table is
made up of columns and records. Columns represent atiributes, or fields, and
records represent different occurrences. Each shape in the layer will correspond
to a record in the table. ,

Viewing the Table

You can manually change the width of columns, as well as sort respective fields
in ascending or descending order.

Drag the edges of column headings to increase/decrease the widths of
columns

Right Click the “YSLB” Column heading, and select the “Sort DESC” menu
item.

Scroll down the table to see that the records have been sorted according to their
“YSLB” value.

Right Click the “YSLB” Column heading, and select the “Sort ASC” menu
item. v

Notice that the records have now been sorted from top to bottom in ascending
order. You can sort both numeric fields and text fields.
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Selecting Records

Selecting records is a function that is used regularly for many GIS tasks. We will
use selections later on in the course. In DECgis you can select features from the
View, or records from the table of the layer.

You can manually select records from the table by clicking in the grey box to the
left of each record, along with using the mouse drag, “Ctrl” and “Shift” buttons,
much the same as in Windows Explorer.

Click on the first record in the table. Hold down the shift key and select the
tenth record.

Note that all records have been selected from the first record to the tenth record.

Select the twelfth record. Now hold down the “Ctrl” Button and select the
third record.

Note that this time only the twelfth and third records have been selected, whilst
all the records in between remain unselected.

Select the first record, hold down your click, drag the mouse down a few
records, then release. This should select a number of records.

These are the ways to select records by manually clicking on the table. There are
other functions which help you select records in a more organised way.

Select the “Selection -> Switch Selection” Menu ltem.

This function will select all the records that were previously unselected, and
deselect all of the records that were previously selected, hence switching your
selection.

Select the “Selection -> Select All” Menu ltem.

Select the “Selection -> Select None” Menu item.

We will now select records based on a criteria. This is called a query.

Select the “Selection -> Query” Menu ltem.

You will now be presented with a Query dialog that will enable you to form criteria
to query your table with:
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Fields: And § -1 o i
DESCRIPT : ;
FUEL_COLOU f o
YSLB Or § > >‘§
Not } < f = §
Like % Help §§
 Cuse | _Apply |

You will need to construct queries with correct syntax. Let's make a simple query.

In the Fields Listbox, double click the “YSLB” Field. Now press the “>”
button, and then type in 5.

Your query should look like this - YSLB > 5.
Press Apply.

You should see that a number of records have now been selected (9646 of
12900), but only the ones that match the criteria of the YSLB column having a
value of greater than 5. How easy was that? Obviously queries can be made to
be extremely complicated, but as you have just seen they can also be relatively
straight forward.

Let’s try to select all of the records that have a YSLB value greater than 5, but
less than 20.

Use your mouse to manually select the query text, and press the “delete”
key to remove the previous query text.

Enter in the following Query: ‘YSLB > 5 And YSLB < 20’. Press Apply (7502
of 12900 records should be selected).

You have now conducted a multi criteria query where records must adhere to two
individual criteria, having a YSLB value of greater than 5, but must also be less
than 20.

Let's try and do some queries with text columns.
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Manually delete the previous query string of characters. Enter in the
following query: FUEL_COLOU = '4 Years'.

Note that you must put text in © for text column queries. Double quotes will not
work, you must use single quotes. The query will not be case sensitive.

Press Apply (756 of 12900 records should be selected).

To make querying string columns easier, you can use the “** wildcard with the
LIKE operator. o

Delete the previous query string. Enter in the following Query:
FUEL_COLOU Like "2*, Press Apply (655 of 12900 records should be
selected).

The ™" wildcard represents any characters, and any number of characters. So
the query we have just done is selecting any records which contain the 2
character, irrespective of what the actual value for the record is. The wildcard is
very useful for selecting records when you are not exactly sure of the spelling.
Press the Help button (on the Query dialog)

Have a read of the help for creating queries and see if you can construct some
more queries. If you don’t have the query worded correctly, you will get a “Syntax
Error”.

Close the Help and Query windows

Viewing Selected Records

To view only the records you have selected press the “Show Selected” Button
Ell . If this button is disabled then you do not have any records selected.

Manually select a few records.
Press the “Show Selected” Button

Notice that your table now only shows the selected records. This is a way of
looking at all of your selected records.

Press the same “Show Selected” Buiton to return to the full view of
your table.

You can tell if you are looking at the selected view of your table or the full view of
your table by moving your mouse on top of the' &l bution. If the tooltip says
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“Show Selected Shapes” then you are looking at the full view of the table. If the
tooltip says “Return to Full View” then you are only looking at your selected
records.

Your view is linked to your table, so if you select records in your table, the
corresponding shapes are selected in your View, and are coloured Yellow.

Press the “Zoom to Selected Shapes™ button &

Your view will now be zoomed over the extent of your selected records

Select the first record on your table. Press the “Zoom to Selected Shapes”
button %

Your view should now zoom directly to the individual shape.

Editing Tables

Manual Editing/Typing

By now you have probably already noticed that you can type directly into the cells
of your table. You can edit your table in this way. If you type an incorrect value in
a cell, eg if you type text in a numeric column, then the change will not take
affect.

Note that the changes you make will not be made permanent until you press the
apply button. So this is kind of an undo, if you make a change but don't want o
keep it, then don't press apply. You should not change the records of any of the
DEC Corporate Datasets. We will open up the table of the “my_tester” layer that
you created previously.

Close the table for the Fuel Age layer, selecting “No” if you are prompted to
save any changes.

Right Click on the “my_tester” layer from the Legend, then select the “View
Attribute Table” option from the Context Menu to open the table for this
layer.

Manually enter one digit numbers (e.g. 5) in the “ID” column of the table, by
manually clicking in the ID cell, and entering the number using the
keyboard.
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Working with Fields

As we have discussed before, columns in the table represent fields for the
dataset, so the two words are interchangeable. Let's look at how you can edit
fields in DECgis.

Select the “Edit -> Add Field” Menu ltem

You will now have a window that will allow you to specify the parameters for your
new field:

Mame: i

Tupe: [[Select one] j;é

Width: o -]

Frecision & R “;é
Carcel_|

There are 3 different types of fields that you can create — Double, Integer and
String. Double and Integer are both numeric fields, the difference being that
double fields allow decimal places whereas Integer fields can only contain whole
numbers.

You can pretty much name your field whatever you ‘like, but we suggest you
avoid using spaces and funny characters, and you try to limit your field names to
less than 12 characters where possible.

The width of fields represent how many characters they can contain. You should
always give yourself a little breathing space, so make the field width a few more
than you think you will need, you don’t want to be caught short.

The precision only applies when you are creating a double field, and sets how
many decimal places your field will allow.

Set the field name as “MyField”, the type as “String” and the width as 20.
Press OK.

Your “MyField” Column should now show up in the table. Type in a few values for
some cells of your new field.

Select the “Edit -> Rename Field” Menu ltem.
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Select “MyField” as the field to rename, then type in “NewField” as the
name to rename the field to. Press OK.

You have just renamed your new column. You can delete a column by selecting

the “Edit -> Delete Field” Menu ltem, and selecting the field you wish to delete,
but we wont worry about that now.

Large Scale Field Editing

There are some bugs with the large scale field editing tools, which will
hopefully be resolved soon, but in the meantime skip to page 32.

There are two ways in which we can edit a number of record values for a
particular field at the same time.

The Calculate Values field function allows you to set the values for all of the
records of that field, irrespective of whether they are selected or not.

The Assign Values field function will only change the values of the records that
you have selected. This function also has fewer capabilities than the Calculate
Values function, as you will see.

Right Click on the heading of your “NewField” Column, and select the
“Calculate Values” Menu ltem from the popup menu.

You will now be presented with the Calculate values window, which will allow you
to set the values of all of the records for that column.

Fields: Type Functions
D +
MwShapelD ™ Mumber Trim(}
MewFigld Substring)
¥ Shing
M ewFieId» =
g :
Cloge | Help ‘% Apply :
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We must now setup a string that will determine the field values. We will start with
something easy.

Type 'Constant’ (including the single inveried commas) in the text box at
the bottom of the window (under “Newfield ="). Press Apply.

All of the values of your “NewField” field should now be set to “Constant”

Clear the text box. Double click the “MWShapelD” field under the fields,
double click “+” under the functions on the right of the window, and type
‘ex’ (including the single inverted commas). Press Apply.

What we have just done is use the values from the corresponding records . of
another field to calculate values for our “NewField”. If you have a look at the
results you will see that the values in the NewField are exactly the same as the
values in the “MWSHapelD” field, but they have “ex” added to the end of the
value. The “+” function combines two string values together for string fields, but
will be the actual plus function when you are working with numeric fields.

Close the Calculate Column Values Window.
Select the first four records of the table (if you have that many)

Right click the “NewField” column heading, and select “Assign Values”
from the popup menu.

You will now be presented with a dialog box that will allow you to specify a value
for all of the selected records of the “NewField” field. This functionality only allows
you to specify constants, you cannot use the values from other fields like we did
with the Calculate Values function.

Enter “Assigned” (without the quotes) in the Assign Values Dialog Box.
Press Enter

All of your selected records should now have “Assigned” in their “NewField”
records. You can enter stiings for string fields, and you can enter numbers for
numeric fields. Do not use quotes when specifying strings.
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Find and Replace

The DECgis Table Editor also affords you the standard Find and Replace
functionality you will find in many software packages, such as Microsoft Word.

Select the “Tools -> Find” Menu ltem

Type in assigned and press Enter.

The first record which contains the text assigned will now be selected.

Select the “Tools -> Replace” Menu ltem

Typé in assigned in the find box and mytext in the replace box. Press Enter

All of the occurrences of assigned in your dataset will now be replaced with
mytext. :
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Close the table for the “my_tester” layer, saying Yes to saving changes.

Table Statistics

DECgis has a statistics function which summarises the values of the selected
records for a specific field.

Select the “fuel_age_mga50” layer from the Legend, then click thie “Table -
Editor” button U to open the table for this layer.

Select the first 10 records of your fuel age table.

Right click on the “YSLB” Field heading and select “Statistics” from the
popup menu.

You should be presented with the statistics dialog:

This dialog gives you the statistics of the selected records for your dataset. If
your “Statistics” menu item is greyed out then the column you clicked on is not a
numeric column. The statistics function only works for numeric columns.

Close the Statistics Window, Close the Table without saving (applying) the
changes, then close down DECgis without saving.
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The Corporate Data Menu

The Corporate Data Menu provides quick, easy access to DEC’s Corporate GIS
Datasets. It also automatically applies the standard symbology for these
datasets.

Open a new DECgis project (Start —> Programs —> DEC —-> GIS -> DECgis).
If you are presented with a Welcome Screen then close it straight away.

Take some time to have a look at the Corporate Data Menu, and the
datasets it provides access to.

You can see all of the Corporate Datasets you have access 1o by looking through
the data menu.

Select the “Corporate Data —> Data Locations” Menu ltem.

The data locations tell DECgis where to look for your Corporate Data. You will
notice on the Data Locations window that there is a “Corporate Data” drive as
well as an “External Corporate Data” drive.

In 2006 DEC is distributing the Corporate Data via local GIS servers, with the
existing "Maxtor” external hard drives remaining as a backup. As well as mapping
to the appropriate server (or external hard drive), people can copy some or all of
the Corporate Data to their own computers, hence data can either be located on
an internal or external drive.

If you are not mapped to an external server/drive then you should set both drives
to your hard drive (usually C:). Otherwise your “Corporate Data” drive will be the
hard drive on your computer (usually C:), and the External Drive will be whatever
drive you have mapped (usually your V:).

If you are using an off-network computer for this training course:
Press the change buttons for both drives and select the C: drive.
Otherwise:

Ensure the first drive is set to C: and the second to V:

Press OK to close the Data Locations Window.

Some of the Corporate Datasets are so large and detailed that they have needed
to be divided into CALM 2005 regions, for example the roads and hydrography
datasets have all been divided into CALM 2005 regions to make them easier and
faster to use.

Select the “Corporate Data —> Choose DEC Region” Menu ltem.
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Select the “South West” region and Press OK.

You will get a warning that the datasets are not divided by the most up-to-date
region boundaries (this is because the GIS Section did not have time to change
the region “cut up” from the “CALM 2005 regions” to the “DEC 2006 regions”).

You should get a notification that your region has been set to “South West”. From
now on, whenever a dataset has been divided into CALM 2005 Regions, the
South West tile for this dataset will be loaded. This will make more sense in a few
moments. o

Using the Corporate Data Menu navigate to “Administration Boundaries”
and select the “DEC Regions 2006” Menu ltem.

The first time you load a dataset from the Corporate Data Menu in a DECgis
project, you will be prompted to select a MGA zone for your data.

OK | CAHWCEL |

The Corporate Datasets that you use with DECgis will be in projected
coordinates, ie eastings and northings. Projected coordinates are only accurate
over a limited area. Projected coordinates attempt to transform a curved earth
into flat, planar coordinates. Over large areas the distortion associated with this
transformation can become large. To account for this, projected coordinates are
divided into zones across Western Australia. If your study area is across multiple
zones then you should choose the zone where the majority of your data lies. If
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you are looking at the entire state, then zone 51 is the most appropriate zone io
choose.

Note that you will only have to specify the zone once for your project, after which
this zone will be used for any Corporate Dataset you load from the Corporate
Data Menu.

Select Zone 50, then press OK

The DEC Regions dataset should now be loaded into your DECgis view, with the
standard symbology applied. Note that this is not one of the Corporate Datasets
that is clipped to respective CALM 2005 regions (it is the updated 2006
boundaries for those regions!)

Use the Corporate Data Menu to load the “Tenure —> CALM Estate” Dataset
Now load the “Topography —> WA Townsites” Dataset

Have a play with these datasets, zoom in and around, and open up the tables for
the respective layers. Training computers usually only have a small subset of all
the Corporate Datasets loaded, so if you try to load a dataset from the Corporate
Data Menu, and you get a message telling you the dataset cannot be found, this
is why.

Orthophotos

Orthophoto imagery is one of the most useful Corporate Datasets that DEC
distributes. Orthophotos are great for providing a background to maps, providing
a real world perspective, and as a navigation tool.

The suite of Orthophoto imagery that DEC provides is exiremely large, around
200+GB worth, and it can take a while to load into your DECgis project if you are

zoomed out too much.

Open the atiribute table for the “CALM Estate” layer (Right Click on the
layer, then select “View Attribute Table” from the Context Menu).

Open up the query window (“Selection —> Query”)

in the query window enter the following text to select all the polygons that
comprise the Yanchep National Park - NAME Like *Yanchep*'.

Press Apply (4 records should be selected), then close the query window.

Press the “Zoom to Selected Shapes” @4\ on the Attribute Table window.
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Close the Attribute Table window.

Your map extents will now be zoomed to the Yanchep National Park. From here
we can load our Orthophotos.

Select Orthophotos from the Corporate Data Menu (“Corporate Data —>
Imagery — Contextual —> Orthophotos™)

A new group layer called “Orthophotos” will be added to your legend, and you will
see the Orthophoto imagery on your view. If you expand the “Orthophotos” group
layer in your legend you will see that there is only one Orthophoto tile over your
particular area of interest. When you load Orthophotos from the Corporate Data
menu, all of the Orthophoto tiles which overlap your view extents will be loaded. If
you change your view exients by panning or zooming out, simply load the
Orthophotos again from the Corporate Data menu and the right Orthophotos will
be loaded into your view, under an “Orthophoto” group layer. -

Have a play with zooming and panning around the Orthophoto, and turning
layers on and off (Be a little patient when turning layers on and off, because
this process takes a little longer when Orthophotos are involved).

Right click on the “Orthophotos” group layer heading in the legend and
select “Remove Group” from the popup Context Menu to remove the
Orthophotos from the DECgis project.

COG Images

COG maps are CALM Operational Graphics maps that poriray detailed
topographic information, including roads and road names, contours and tenure.
DEC distributes digital versions of these COG maps as part of the DEC
Corporate Data, which can then be loaded into DECgis projects.

Like Orthophotos, COG maps can provide an excellent background in DECgis,
and are also a useful tool for navigation purposes.

Ensure you are zoomed in around the Yanchep National Park, then load the
COG Maps from the Corporate Data Menu (“Corporate Data —> Imagery —>
Contextual —> COG Maps”)

A “COG Maps” group layer will now be loaded into your legend, and you will see
the COG maps on your view. Expand the “COG Maps” group layer in your legend
and you will see all of the COG Map images which have been loaded into your
project. COG Maps are loaded in the same way as Orthophotos, they will be
loaded to cover the extent of your DECgis view.
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DEC Tools

Coordinate Systems

DECgis requires that all of your datasets be in the same coordinate system, so
that they all overlay nicely.

Right click on the “COG Maps” group layer heading in the legend and
select “Remove Group” from the popup Context Menu to remove the COG
Maps from the DECgis project.

If you add in a shapefile that is stored in a projection that differs from the
projection of the project, then you may get a message like:

Warning: The projection specified in the project settings differs
from the projection of the layer you're adding.

How would you like to proceed?

¥ Lise this answer for the duration of this session

o~ Feproject the laver you're adding to match the
’ projection of the project

% DoNothing [Data may not appear as expected)

I MeverShow This Again [Always "Do Nothing) Ok «j

This dialog box gives you the option to automatically project your data into the
correct projection to maich up with the layers already added to your project.
However, we recommend that you select the Do Nothing option if this dialog
appears and use our DEC Tools for changing projections instead. The following
example takes you through changing projections with the DEC Tools. The
shapefile we will use has no projection information defined (this is the case for
shapefiles created by the Garmin GPS importing tool), so the dialog above will
not appear anyway.
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Manually add the “C \GlS‘I»Corpcrate\daia\tralmng\
fauna_habitats_decgis_gda.shp” shapefile (Add Layer Button ¥ )

The fauna_habitats_gda layer has been added, but because the layer is in a
different projection, ie Lat/Long and not Eastings/Northings, the layers will not
maitch up.

Right Click on the “fauna_habitats_decgis_gda” layer, and select the
“Zoom to Layer” item from the popup Context Menu.

You will notice that the fauna habitats do not overlay on top.of the CALM Estate
or any of the other layers in your project. We will need to change the projection of
the fauna_habitats_decgis_gda layer so that all of our layers do overlay correctly.

Select the “View —> Previous Zoom” menu item to return to your previous
extents.

Make the “fauna_habitats decgas gda” active, by clicking on the layer
name in the legend

Select the “DEC Tools —> Coordinate Systems —> Change Projection” menu
item.

You should then be prompted to specify the projection that the
“fauna_habitats_decgis_gda” layer is currently in (this is the input layer). We
obviously need to know what projection a layer is in before we can change the
projection.

Specify the coordinate system to be a Geographical Coordinate System —
Geocentric Datum of Australia 1994 (GDA).

~Set Coordinate System
{* Projected Coordinete System

& Geographic Coordinate System

Geocentnc Daturm of Australia 1994 (GDA) v

4
0K § _ CANCEL
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Press OK to accept the specified coordinate system.

You will now be prompted to select the MGA zone to project your data to. We are
working in the South West, which is in MGA zone 50.

Trn 49 Fona 6%

1y
ik

]
"f{:';

Zone g@m _";ﬂ

k: ]
0K § CANCEL 1

Select Zone 50, then press OK.

You will then be presented with a confirmation window ensuring that what you
are doing is what you want to do, which in this case it is, project our shapefile into
MGA Zone 50 coordinates.

Press OK to confirm the projection specifications.

You will now be asked to specify the filename for your new projected shapefile,
and where to save it.
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Savejn: | % Training v%

,3 St

@ drop._bears.pt.shp iCreate New Folder I

il L:f&ﬂ_' Fauna_habitats_gda.shp
My Recent ?ﬁ]Fauna_habitats__gda_mgaSD.shp
Docum?nts Fauna_habitats_gda_reprojected.shp
Fauna_sightings_gda.shp
Fauna_sightings_gda_maa50.shp

Deskiop

gjleewin_naturd_agd.shp
. ) my_tester.shp

by Documents

by Computer

%

by W stwok  File name: Efauna_habitats_decgis_mgaﬁd |
Places - ,

B P U RURRR .

Save astype: | Shapefiles [*.shp) v Cancel §

Save the shapefile in the “C:\GIS1-Corporate\Data\Training\” Directory, and
call it fauna_habitats_decgis_mga50.

Press Save.

You will then be asked if you want to load your new shapefile.

Select “Yes” when prompted if you want to load your new shapefile.

If you zoom to the new fauna_habitats_decgis_mga50.shp which you have just
created you will see that it correctly overlays the other Corporate Datasets that
have already been loaded into the project.

Under the “Coordinate Systems” section of the “DEC Tools” menu, you will notice
that there is a “Change Datum” function. This function allows you to change back

and forth from the old AGD datum to the current GDA datum. We won't go into
this now, but if you ever need to do this, then ring the GIS section on 93340158,



Metadata

Metadata is information about datasets. Metadata usually refers to documents or
statements which contain information about the datasets, such as the coordinate
system of the dataset, the date the dataset was created, the title of the dataset

and much, much more.
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-> Metadata -> Edit Metadata” Menu Item.

You should be presented with the following window:

Title

I

Custodian 1

Endirg Date |

Beginning I

Bate

Datum

Projection

Fone

~Coordinate System

[Geacertric Datum of Australia 195¢ |

R

B

zMap Grid of Australia (MGA)

Abhstract

e

i Sulvanoed

CANCEL 0K

A Metadata file was created for this dataset when we created it by projecting our
If no Metadata file exists then you will have to
create one first by selecting the “DEC Tools -> Metadata -> Create Metadata”
greyed out, that means that a metadata document

original fauna habitats dataset.

Menu ltem. f this menu item is
already exists.

Select your “fauna_habitats_decgis_mga50” layer which you just created.

Once you have this layer highlighted in your legend, Select the “DEC Tools




42

The Metadata document type we are using is an XML document. | won't go into
this in more detail, but there is plenty of information on the web regarding XML if
you are interested. The XML Metadata documents are named exactly the same
as the shapefiles, with a “xml” file extension, eg “C:\GIS1-
Corporate\datal\training\fauna_habitats_decgis mga50.shp.xml”.

Enter Some Data for the Title, Custodian and Description.

Check the “Advanced” checkbox at the bottom left of the Metadata window,
a new “Advanced Metadata” section of the window should appear on the
right.

Title ] [
Custodian | | Advanced
Ending Dste [ ] Metadata
Beginning s i
Date L ! Contsct Access .}@uauty;} Status | Addtional 4] ¥ |
—Coordinate Swstem
Datum ‘Geocentric Datum of Australia 199¢ + | StoredNateEiinad
; st ore a Form
. ; - - 4 Wector
Prajection  ivan Grid of Australia (MGA) =]
o Aceess Constraints
Zone géb vi
Abstract
W Advanced CAHCEL | 0K f
: i 3

The advanced metadata allows you to view and edit a wide range of information
relating to the dataset, such as contact details, and information pertaining to the
quality of the dataset. You can choose to enter as little or as much information as
you like.

Have a look at the advanced Metadata and enter in some random values for
some of the fields.

The “Edit Metadata” function is also a nifty way to view the metadata, however
there is “View Metadata” function that will also do this.




43

Press OK on the Metadata Window to accept what you have entered and
close the Metadata window.

Select the “DEC Tools -> Metadata -> View Metadata” Menu Hem.

This function allows you to view the XML metadata using a predefined CALM
stylesheet, which arranges the information to make it easier to understand.

Close the Metadata window.

Close your DECgis project without saving, you will start a new project for
the coming exercises.
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Other DEC Tools

There are a number of other functions under the DEC Tools menu in DECgis that
provide very useful and easy to use functionality.

Open a new DECgis project (Start —> Programs —> DEC ~> GIS ~> DECgis)

If you are presented with a Welcome Screen then close it straight away.

Shapefile Export

This nifty little function allows you to export the selected shapes of a layer (along
with their corresponding records) to a new shapefile.

Load the “CALM Estate” dataset using the Corporate Data Menu
(“Corporate Data —> Tenure —> CALM Estate”). Select Zone 50 when
prompted for a MGA Zone,

Use the shape select tool & to select a few of the CALM Estate shapes
(Drag a Rectangle around some shapes), they should turn yellow.

Select the “DEC Tools -> Shapefile Export” Menu Iltem, and save your new
shapefile at “C:\GIS1-Corporate\data\training\” and call it “MyExport”.

Click Save.
Press Yes when you are asked if you would like to load the new shapefile.

You will notice that your new shapefile is an exact match to the selected shapes
of the CALM Estate layer. If you open up the table for your new “MyExport”
shapefile you will see that the table records are also an exact maich to the
corresponding records in the CALM Estate layer.

The Shapefile Export function can be used in a number of ways. If you wish to
make a copy of a Corporate Dataset so that you can edit it and make some
changes, then you can use the Shapefile Export function, after selecting all of the
shapes/records, to make an exact copy.

The Shapefile Export function is also useful for extracting particular shapes out of
a shapefile that may be of special interest. For example, it may be useful to
extract only the “Boyanup State Forest” shapes from the entire CALM Estate
dataset, to make a map of only the “Boyanup State Forest”.
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Table to Shapefile

The “Table to Shapefile” function allows you to create a shapefile from a table
which contains x and y coordinates. For example, if you are emailed a
spreadsheet containing GPS waypoint ID’s, along with their x and y coordinates,
you could create a shapefile from this using the “Table to Shapefile” functionality.

Select the “DEC Tools —> Table to Shapefile” Menu ltem.

You will now be presented with the “Convert Table to Shapefile” window.

Input Dataset

|

Shape Type éPoint M

XField | ) -]

YField | -]
: JRR. 3

Output Shapefile

CANCEL f OK

Use the ‘dl button to the right of the “Input Dataset” box to select the
“C:\GIS1-Corporate\Data\Training\apiary_sites_gps.xls” file. Make sure you
select “Excel File (*.xIs)” as the type of file, ctherwase you wont be able fo
see the apiary_sites_gps.xls file. :

Click “Open” and type in “apiary_sites_mga50” if prompted for the sheet
name (Excel spreadsheets can contain multiple sheets).

The X and Y field will be automatically populated if suifable columns in the table
are found. In this case the X Field is XCoord and the Y Field is YCoord.
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i
Use the [ button to the right of the “Output Shapefile” box to set the
output shapefile as “C:\GIS1_Corporate\data\training\apiary_sites.shp”.

Press Ok on the “Convert Table to Shapefile” window to execute the
process.

You may be asked to enter the sheet name again, if so once more type in
“apiary_sites_mga50” (don’t ask my why you have to do this)

You should then be asked if you would like to load the shapefile, Press Yes.

Zoom to your new “apiary_sites_mga50” layer, and have a look at your
points.

Export Map Image

This function allows you to save your DECgis view as a georeferenced bitmap.
Select the “DEC Tools —> Export Map Image”.

Save the image at “C:\GIS1-Corporate\data\training\MyMapimage.bmp”.
Press Save.

As well as creating the image file MyMaplmage.bmp, this has created the “world

file” MyMaplmage.bpw. This is a tiny text file that tells GIS software how the
image relates to real-world coordinates.

Clear all of your Layers (Right click on the legend, then select “Clear
Layers”)

Add your bitmap image as a layer (%, then select “MyMaplmage.bmp”)

This image, and its world file can be emailed, and used as a background to

whatever data you are looking at in DECgis, just as if it were an orthophoto or
COG image.

Import ArcView AVL

ArcView 3.x allows symbology to be stored for shapefiles in files with .avl
extensions (ArcView Legend Files). The “Import ArcView AVL” function allows
you to import the ArcView 3.x symbology for a shapefile into your DECgis project.
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Add the “V:\GIS1-Corporate\Data\Fire\State\fuel_age_mga50.shp” shapefile
to your DECgis project.

You will notice that the fuel_age_mga50 layer has just been assigned arbitrary
colours.

Click the “DEC Tools —> Import ArcView AVL” menu item.

You will now be prompted to select the avl legend file to apply to the active layer
in your project. A

Select the “V:\GIS1-Corporate\Data\Fire\State\fuel_age_mga50.avl” file and
press OPEN.

The avl symbology file will then be applied to your fuel_age mga50 layer,
colouring the layer up according to the age of the respeciive fuel age shapes.

Add XY Coords

The “Add XY Coords” DEC Tools function adds coordinate fields to the active
shapefile, populating the fields with the X and Y coordinates of the shapefile.

Note that this function will only add the XY coordinates for point shapefiles, and
will not work for polygon or line shapefiles.

Add the “C:\GIS1-Corporate\Data\Training\fauna_sightings_mga50.shp”
shapefile to your DECgis project.

When you add a layer, that layer automatically becomes the active layer in your
project. The “Add XY Coords” function creates coordinate fields for the active
layer in your project.

Click the “DEC Tools —> Add XY Coords” menu item.

Open the attribute table for the “fauna_sightings_mga50” layer (Right Click
on the layer, then select “View Attribute Table” from the Context Menu).

You should see that two fields have been added to the attribute table of that
“fauna_sightings_mga50” layer, a “XCoord” and a “YCoord” field, both of which
are filled with the coordinate locations of each respective point in the shapefile.
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Garmin GPS

The DEC Tools menu has a Garmin GPS section, which provides functionality to
automatically connect to your Garmin GPS, download and upload iracks and
waypoints directly to your GPS and save tracks and waypoints directly from your
GPS into a shapefile. You will need a Garmin GPS to complete the following
GPS exercises, so if you don’t then skip to page 50.

Qonnect your GPS to your computer, preferably through COM Port 1.

Turﬁ your' GPS on |

Select the “DEC Tools —> Garmin GPS —> Connect to GPS” Menu ltem.

You should get the following message, indicating that you have successfully

connected to your GPS. Note that this functionality will only work with Garmin
GPS units, and may not work with very old Garmin GPS units.

Succesful GPS Connected

If you could not connect to your Garmin GPS, iry changing the ports your GPS is
connected io.

Once you have successfully connected to your GPS you will gain access to all of
the GPS functions in DECgis.

Under the “DEC Tools -> Garmin GPS -> Waypoints” menu you will have three
functions: Download Waypoints, Send Waypoints to GPS, Create new Waypoints
shapefile.

Use the Download Waypoints function to directly download and save the
waypoinis from your GPS to a shapefile. Note that the points will probably be
download in geographic coordinates even if they are recorded in MGA
coordinates on the GPS. To convert a shapefile in geographical coordinates to
one in projected coordinates you will need to use “DEC Tools -> Coordinate
Systems -> Change Projection”. Remember that if asked to set the projection of
the input layer, this will need to be set to “Geographic” and only then will you be
asked the projection that you wish to go to.




49

The Send Waypoints to GPS function will allow you to directly upload waypoints
into your GPS, from an existing shapefile, or from an existing layer in your
- DECgis View.

The Create New Waypoints function allows you to create a new shapefile, into
which you can digitise waypoints, with all of the correct fields being setup for you
automatically.

The Tracks Menu offers the same functionality as the Waypoints menu, except
the functions relate to track GPS data, not waypoints.
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Google Earth

Google Earth is a fantastic GIS imagery viewer that provides access to aerial
imagery across the entire world. For more information regarding Google Earth
software refer to http://earth.google.com. It is up to you to ascertain whether
your proposed software use meets any Google Earth license conditions and
download (or not download) the sofiware accordingly.

Google Earth provides 3D visualisation functionality, which DECgis does not, so
there are functions on the DEC Tools menu of DECgis to link your DECgis
project into Google Earth, so you can view your data in 3D.

DECqis provides 3 Google Earth related functions. The first function, is to export
your current DECgis view to Google Earth. This selecis the visible shapes from
all of the layers (shapefiles only) in your DECgis project and recreates them in
Google Earth. It also gives you the option of saving a “KML” file to a specified
location. This KML file can then be emailed and viewed by other people on other
computers using Google Earth, so essentially you can transport your DECgis
view as a Google Earth KML file.

DECgis also provides a “Export Layer to Google Earth”, which will recreate the
active layer in Google Earth, irrespective of which shapes in the layer are visible,
and where you are zoomed into on your view.

The third Google Earth function provided by DECgis is the ability to create a
Google Earth fly through. With this option selected you can draw a line using left
mouse clicks and a right click to finish the line. You will then be asked if you
would like to export the DECgis view (all of the visible shapes in all of the layers)
to Google Earth, along with the fly through. Once Google Earth is launched you
should see a faint grey line, which should be an exact replica of the line you
digitised in DECgis. To play the the fly through you select the “Fly Through” layer
in the Google Earth table of contenis and click the “Play” symbol button. You can
change Google Earth’s fly through settings under Tools — Options — Control
Tab (Select Advanced section checkbox).
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GIS Tools

There is a GIS Tools plugin for DECgis that provides access to more advanced
GIS functionality. When the GIS Tools plugin is turned on you will have a “GIS
Tools™ menu on your main menu bar for your DECgis project. To turn the GIS
Tools plugin on or off simply select the plugin from the “Plugins” menu.

Calculating Areas

Calculating areas for shapefiles is very easy with DECgis. You have the ability to
specify the output area units, for example acres or hectares.

Close your DECgis project without saving, and then open a new project.

If you are presented with a Welcome Screen then close it straight away.

Add the “fauna_habitats_decgis_mga50” shapefile from the

“C:\GIS1-Corporate\Data\Training” directory (you created this earlier in the

course)

The area calculation function creates a new column or overwrites an existing
column in the atiribute table of the active layer in your DECgis pro;ect which

specifies the area of each respective shape in the shapefile.

Select the “GIS Tools — Vector —> Calculate Polygon Areas” menu item.

A window will popup which will allow you to configure the area calculation.

This tool will calculate the area of each polygon in the given
polyogn shapefils, storing the arsa in the specified field.

Shapsfie in which to Calculate Palygon Areas;

& Use aloaded layer

; fauna_habitats_decgis_mgaSD vl

o
o , ey 1
" Use an extemal file.. sﬁf |
Field to store areas in:

£" Update {overarite] an existing field

fid ™ ”::3

% Use a new field called: jHectares New

Shapefile Units: IMetars

sk

H
[T

Area Units:

Caloulate | Llose !§
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The first option you can configure is which layer to calculate areas for. By default
this will be the active layer in your project, but you have the ability to select any
loaded layer, as well as selecting any shapefile on your computer that hasn't
actually been loaded to your DECgis project. Generally you will be calculating the
area for your active layer, in which case you do not need to modify this option.

The second option allows you to specify the field that the area values will be
placed in. You have the option of placing the values in an existing field, or
creating a new field for your shapefile to store the values. Creating a new field is
probably the best option, however if you already have an area field for your
shapefile and you want to update it, then updating this particular field might be
the best alternative. '

The other, and most important options relate to the area calculation. The
shapefile units option needs to represent the units that your shapefile uses, which
in most cases should be meters. If you are looking at a shapefile based in
geographical coordinates, then it would be a good idea to use the DEC Tools to
project the shapefile into MGA coordinates so that accurate area calculations can
be made.

The area units option allows you to specify the output area units to be calculated.
In general DEC uses hectares, but you can use acres or metres squared or
kilometres squared if you wish. It is good practice to name your area field based
on the area units you are calculating, for example if you are calculating your area
in hectares, then your field name should be “hectares”.

Leave the “Use a loaded layer” as the “fauna_habitats_decgis_mga50”
layer, change the “Use a new field called:” value to “Hectares New”,
ensure the “Shapefile Units” are set to “Meters”, then set the “Area Units”
to “Hectares”.

Press Calculate.

A message box should now be displayed ensuring you that the process was
successful. Click Ok to this.

Open the attribute table for the “fauna_habitats_decgis mga50” layer
(Right Click on the layer, then select “View Attribute Table” from the
Context Menu).

There should be a new column in your attribute table called “Hectares New”.
There will also be a column called “Hectares”, which is an area column that
already existed in the shapefile. The “Hectares” column and the “Hectares New”
column should contain the same values if the process worked correctly.
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Other GIS Tools

There are a number of other functions provided by the “GIS Tools” plugin that
may be useful: (Source:
http://www.mapwindow.org/wiki/index.php?iitle=GISTools:Raster)

Raster (Imagery):

Assign Projection to Grids:

This tool allows the user to assign a projection to a raster data object. The
projection data is written to the grid, but no actual reprojection occurs. This is
functionally equivalent to ESRI's “Define Projection” tool.

Reproject Grids:

This tool will take an existing grid and reproject the data to another projection.
The user will be prompted for a destination projection and the conversion will
take place. If the grid’s current projection cannot be determined, the user will be
prompted to specify the current data projection as well.

Change Grid Formats:

This tool will allow the user to convert from one grid storage format to another.
This tool also allows resampling of the grid during conversion. Conversion
between formats would be between ESRI Grid to USU Binary Grid, for instance,
while a resampling would be changing the data type from integer to double.

Create Grid Images:

This tool will create a georeferenced image of the grid’s data content according to
one of several preset coloring schemes which the user will be prompted to select
from. These include ‘Desert’, ‘Fall Leaves’, ‘Summer Mountains’, and ‘Valley
Fires’, among others.

Merge Grids:
This tool will take two or more grids and merge them into one grid. Any area

where data is missing will be filled in automatically with the grid’s No Data value.
Input grids should all be in the same projection.




54

Resample Grids:

This tool will allow the user to resample the grid from one data type to another.
An example would be changing the data type from integer to double.

Vector (Shapefiles):

Assign Projection to a Shapefile:

This tool allows the user to assign a projection to a shapefile data object. The
projection data is written to the shapefile, but no actual reprojection occurs. This
is functionally equivalent to ESRI’s “Define Projection” tool.

Reproject a Shapefile:

This tool will take an existing shapefile and reproject the data to another
projection. The user will be prompted for a destination projection and the
conversion will take place. If the shapefile’s current projection cannot be
determined, the user will be prompted to specify the current data projection as
well.

Buffer Shapes:

This tool allows the user to create a shapefile containing polygons of buffers
around a specified layer or shapefile. For example, a buffer shapefile can be
created at 20km around townsites to see if any threatened ecological community
site exists within 20km of a townsite.

Clip Polygon with Line:

This tool allows the user to create a new shapefile by clipping an existing polygon
shapefile with an existing line shapefile. For example the user could cut off an
area of interest polygon by a road line, so that the area of interest is restricted to
a particular side of the road.

Clip Shapefile with Polygon:

This tool allows the user to clip any point, line or polygon shapefile with a specific
polygon shapefile. For example, a user could clip a Road line shapefile with a
State Forest Polygon, to make a new shapefile of only the roads that occur within
the particular State Forest.
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Erase Shapefile with Polygon:

This tool allows the user to erase a section of a shapefile based on a particular
polygon(s) from another shapefile. For example, if you wanted to create a new
apiary site shapefile that excludes all of the apiary sites that occur within a
specific Forest Block then you can use this function to achieve this.

Merge Shapes:

This tool allows the user to merge two shapefiles into one shapefile. The
shapefiles must both be the same shape type, either point, lines, or polygons. For
example, if a user had 2 gps point shapefiles that needed to be merged into one,
then this function would achieve the desired result.

Note: The “GIS Tools” functions can be a little buggy, because they are quite
new. If you need any help or advice in using any of the functions available
through the “GIS Tools” plugin, then please do not hesitate to call the GIS
section.
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Comiusien

DECgis is an evolving open source software package, so look for updates at
least every year. DECgis is highly customisable, so if you like what you see and
would like to incorporate some new functionality, such as a customised data
capture tool or anything else, then contact the GIS section and let them know.

If you have any further queries regarding DECgis then call the DEC GIS section
on 93340158. Good Luck!



